Repair Geometry in ModelBuilder, invalid input when using inline variable sub

2003
2
08-09-2012 09:43 AM
KellyReeves
New Contributor
I am using the Repair Geometry tool in the middle of my model. It worked fine when I passed it a specific feature class as the input feature, but when I changed all the file paths for the feature classes in the model to have an inline variable substitution for the workspace, the Repair Geometry tool gave me the error (000314) that the input feature "is not a Shapefile or a feature class in a Personal or File Geodatabase." My workspace variable is called "Output" and it contains the path to a geodatabase. So my input feature for the Repair Geometry tool is: %Output%\NameOfFeatureClass.

All the other tools in the model are not broken by using this inline variable substitution for the geodatabase path.

I tried to pass the Repair Geometry tool the output from the Make Feature Layer, since that's how I've fixed tools that require a layer input. However, in this case the Make Feature Layer tool did not help.

Has anyone else had this problem or have ideas for how to fix it?
0 Kudos
2 Replies
CristoferByers
New Contributor
Passing the output of the Feature Class to Feature Class tool to Repair Geometry will work with inline parameter substitution, since the output of that tool is guaranteed to be a Feature Class.

I've been trying to find a way to use Repair Geometry with parameter substitution without using the FC to FC tool, since it has some unfortunate table updating problems when the input changes, but to no avail.
ShitijMehta
Esri Regular Contributor
Are you using 10? sp?

This is a know issue and has been addressed in 10.1 sp1.
0 Kudos