Read-Only Parameter in Model Builder?

642
2
10-23-2012 04:26 AM
NicholasGross
Occasional Contributor II
I have a model that results in a table being joined to a feature class, neither of which are initially present in the map document (they're both created in the model). So, in order to get the feature layer and table into the map while preserving the join, I'm using the "model parameter" option from the model builder context menu. The problem is that these parameters are then available for modification in the tool dialog, which is unnecessary in this situation and undesirable. Is there a way to hide these parameters or make them read only?
0 Kudos
2 Replies
MarcinGasior
Regular Contributor
You can prevent parameter from showing in tool dialog by deleting it from parameter list.

Just enter model tool properties, in Parameters tab select the parameter and click X button.
The parameter is deleted only from a parameters list and can be added back by clicking + button.
0 Kudos
NicholasGross
Occasional Contributor II
You can prevent parameter from showing in tool dialog by deleting it from parameter list.

Just enter model tool properties, in Parameters tab select the parameter and click X button.
The parameter is deleted only from a parameters list and can be added back by clicking + button.


Ah, I thought you had my solution for a moment! Unfortunately, it seems that deleting the parameter from the list in the tool properties also removes the "model parameter" designation from the model. I need the model to still treat the output as a parameter so that it will be added to the map.
0 Kudos