Raster Function not working in custom Export Web Map Task

194
0
10-23-2019 12:03 PM
TrevorSkelton
New Contributor

I published a custom Print Tool, Export Web Map Tool, to the Arc Server(10.6) so I could point the print tool to our custom template folder. I followed the instructions here Publish an additional print service with custom layouts from ArcMap—Documentation (10.5) | ArcGIS En... and everything went as expected. It works normally except for one thing. In my webmap json input I included an Image Service layer and a renderingRule (Raster Function) for server side processing on it. When the print image comes back the layer isn't there. If I remove the renderingRule from the webmap json, the custom print tool will show the Image Service layer.

The strange part is the same exact webmap json when input into the default utilities/PrintingTools/Export Web Map Task, the image returns the result as expected with the raster functions applied.

I've tried just making another plain copy of the default print tool. I made it point to all the default templates and everything. I still get the same errors all around. It seems the server won't apply the raster functions for any custom print tool I publish.

In the Arc Manager logs for the custom print tool, when I include the renderingRule in the webmap json, it says "bad syntax in request (status code 400)". The server log states: "code=103800 methodName='Map.Draw' "

According to this page Map service log codes—ArcGIS Server Administration (Windows) | ArcGIS Enterprise  its a LayerDrawingError. What does this mean to me? How do I fix it?

Does anyone have any ideas?

0 Kudos
0 Replies