Raster Clip and background processing - how long is too long?

2250
1
10-21-2014 06:09 AM
SAMStewardship
New Contributor

Hi,

I'm having trouble clipping a raster using a series of polygons. I have two land cover layers (one vector, one raster) that I want to cut to private land polygons in order to assess the land cover types on private lands.

It seems to me to be straight forward and work with no problems when I clipped vector to vector (these are large files with 1372894 and 68977 polygons each, I expected some time delay). I have my clipped file and ran some statistics, it worked out great.

I then started to assess the raster file using the raster clip tool. It doesn't seem to be working... it states that the tool has started and then nothing happens, though Arc tells me that I cannot use the file as it is processing in the background. I've left it running overnight and still nothing? The raster file is only 175 mb so I'm not sure why it is not working.

I've extracted certain layers out using the extract by attributes tool only to have the same thing happen when I attempt to clip the subset of the raster to the private land polygons. The extract by polygon tool only allows you to provide the centroids of a few polygons.

I am hoping someone can help me. Should I wait longer? or is there a different tool that would be more appropriate. I've attached a results window from the raster clip i attempted with a subset of the raster.

Thanks

Dan

0 Kudos
1 Reply
curtvprice
MVP Esteemed Contributor

I would check your inputs and make sure that they are indeed lining up with one another.

For best results, project your polygons to the same coordinate system as the raster to avoid having to do any projecting on-the-fly. You can often mix vector and raster datasets of different coordinate systems just fine, but if you project it ahead of time this gives you more control and can avoid problems.

Hope that helps...

0 Kudos