Project Raster and 999999

10-09-2020 01:39 AM
New Contributor III

We are trying to project large rasters (.tif), horizontally and vertically, using Project Raster. This has been run many times successfully, but now we are getting a 999999 error. The Project Raster has actually completed on an ~83 Gb tif (after many fails, the process completed once or twice), and on 53 and 23 Gb, and many times on 8 Gb tifs, but now the 999999 error occurs every time no matter the size. The error occurs within the first second with a message "Failed to open raster dataset, No such file or directory." But that is not the case!

We were using ArcGIS Pro 2.6.1 on Windows 10 Desktop PCs.

This is occurring on 3 separate PCs, having 24, 32, and 64 Gb RAM.

The computers are in different physical locations and there are 2 different users running this using their own files on local machines.

I have tried: updating to Pro 2.6.2, restarting the computer many times, starting with a fresh ArcGIS Pro project, making sure I have write permissions to all directories, clearing out the Default.gdb, home and scratch folders, cleaning out the user\AppData\local\temp folder, using short filenames with no spaces or odd characters and doesn't start with a number, using short pathnames, putting the input on a secondary internal hardrive and writing to an external drive, ran a different geoprocessing tool (hillshade) on one of the rasters to make sure the file wasn't corrupt, tried file gdb raster format, there is plenty of disk space.

Any ideas? Anyone else have this problem?

Project Raster 999999 error message 

0 Kudos
3 Replies
MVP Notable Contributor

Can you actually open it in ArcPro and say change the symbology and zoom in/out, to confirm that it is not the input raster that is corrupted? Also how big is it?

0 Kudos
New Contributor III

Yes, it can be opened and symbology changed. It is not the raster that is corrupt.

The error has been happening on file sizes ranging from ~3Gb to 83 Gb.

At the beginning of our workflow testing, the files (.tif format) would occasionally complete successfully using Project Raster, then we had the failures described above every time. 

We eventually had a successful Project Raster run when using a file geodatabase raster as the input and output file format on a 100.17 GB file. Processing time was 14 hours, 36 minutes on the 64 Gb RAM PC.

Still don't know why the geotiff files would fail.

0 Kudos
New Contributor II

Hi! A late reply and I don't know if this helps, but I just got a similar error from when running a Python macro on 2.5. The culprit turned out to be arcpy.env.parallelProcessingFactor = "100%" earlier in the code. Took me a while to figure it out, especially when the kernel seems to remember the setting from a previous run even if you remove the line from the code...

0 Kudos