Problems with Copy and then Adding Field

243
1
03-28-2014 02:39 PM
LayneSeely
New Contributor
Folks - I'm using Win7 and ArcGIS 10.1 SP1.  I have a model that I built years ago in 9.3.1 that has always worked flawlessly.  Now that model crashes ArcCatolog when it tries to add a field to a featureclass that has been copied from one FGDB to another FGDB.

I've tried saving the old Toolbox to a v10 Toolbox and have completely rebuilt the model in 10.1 and still it continues to crash.  When I look at the FGDB where the FC was copied to - it displays a geodatabase table and not a featureclass.  I'm guessing that is why it is crashing.  Why then would both tools (i.e. Copy and Copy Features) produce a table when the source data is a featureclass?  The feature class in question displays properly in both ArcCatalog and ArcMap so I don't think that the original is corrupt.

Any ideas or suggestions?

Layne
0 Kudos
1 Reply
benberman
Occasional Contributor
You are more than likely encountering this issue because you can open 9.3 in 10 but not the other way around. Because the model is v9.3 it crashes when you incorporate v10 entities into it. You can open the model in v10 and do a save as and then reattempt your workflow and see if that may resolve the issue.
0 Kudos