Problem with "Parse Path" in Model Builder

03-05-2012 05:37 AM
New Contributor
Hey there,

I ran into a problem with a model I have created that uses the "Parse Path" tool. Up to now it has worked perfectly but since this morning I can't get it to work. I use an ID that is part of the name of an exiting feature class to create the name for a new feature class. Therefore I use the "Parse Path" tool with the parse type "NAME" to get the name of the existing feature class, and use the result in the "Feature Class Name" field of the "Create Feature Class" tool. So far so good, as I said that worked fine for me. But suddenly the "Parse Path" tool seems to add a closing quotation mark to the name of the existing feature class which obviously causes an error in the "Create Feature Class" tool (attached picture). So my question is: What is causing this and how can I avoid it?

Many thanks in advance,

0 Kudos
1 Reply
Esri Contributor
Hi David,

it's not possible to say why this happens; it ought not happen.
To investigate, we'll need the model plus data. Please send both and we'll look into it.
For now, if the model is not too large, recreate it and see if that takes care of it -- many times it does.
I created a model with Parse Path and CreateFC using German data and had no issue on either 10 or 10.1.

0 Kudos