Model Builder Overwriting my final output

564
6
Jump to solution
06-12-2014 04:55 AM
JohnByrne
New Contributor
Hi,

I am trying to create a grid index based upon an ID field and have managed to create the workflow in model builder and everything is working great until the final output where the process overwrites the final output.

I have attached a picture of the workflow in model builder so you can see the steps taken and hopefully offer some advice.

Thanks

John
0 Kudos
1 Solution

Accepted Solutions
George_Thompson
Esri Frequent Contributor
You may need to look into have an In-line Variable Substitution. This should allow you to have multiple outputs that are from the iterated tool.

http://resources.arcgis.com/en/help/main/10.2/index.html#//00400000001n000000

These examples may help better clarify what needs to be completed.
--- George T.

View solution in original post

0 Kudos
6 Replies
George_Thompson
Esri Frequent Contributor
John,

Do you have the "Overwriting the outputs of geoprocessing operations" option checked?

http://resources.arcgis.com/en/help/main/10.2/index.html#//00210000000q000000

Hopefully this helps...

-George
--- George T.
0 Kudos
JohnByrne
New Contributor
Thanks George,

Yes I do but essentially I want to produce several final outputs so they are relevant to each ID Field. I have also ran the process with the overwrite both on and off.
0 Kudos
George_Thompson
Esri Frequent Contributor
You may need to look into have an In-line Variable Substitution. This should allow you to have multiple outputs that are from the iterated tool.

http://resources.arcgis.com/en/help/main/10.2/index.html#//00400000001n000000

These examples may help better clarify what needs to be completed.
--- George T.
0 Kudos
JohnByrne
New Contributor
Hi George,

When I try using any of these invariable strings I get an error stating that there's an invalid string and it either stops the process or crashes it completely!!
0 Kudos
JohnByrne
New Contributor
George, in fact your help was perfect.

Thanks
0 Kudos
George_Thompson
Esri Frequent Contributor
John,

I am glad that you were able to get it working!

-George
--- George T.
0 Kudos