Map Packaging with Mosaic Dataset

316
1
08-23-2011 08:28 AM
MichaelSzaszy
New Contributor
I am having trouble packaging a map containing a mosaic dataset (note: creating a layer package for just the mosaic dataset layer also fails).  When I try to package such a map through ArcGIS Desktop's File->Share->Map Package workflow I get an error stating "Invalid Function argument".  When I do this using the Package Map GP tool the tool  simply fails with a "ERROR 999999".

I tried this with CADRG and DTED data.  When I use a map where I add the CADRG rasters individually onto the map (e.g. no Mosaic Dataset) the packaging works fine.  In the case of CADRG this seems to happen after the raster files are converted into the File Geodatabase Rasters.

Has anyone else tried using the packaging tools on mosaic datasets at 10.1 and seen this behavior?  I know most of this worked at 10.0.

Thanks,

Mike

Edit:

Environment:
Win7 x64 and Win 7 x86
Mosaic Datasets stored inside fGDB
1 Reply
MattGoodman
New Contributor III

I know this is an old post, but I am currently experiencing this same issue with 10.5.1. Getting a 'general function failure'.

0 Kudos