Intersect Tool Not Completing Functions

788
2
05-02-2012 02:33 PM
JennaBernabe1
New Contributor II
I have been using the intersect tool between two fairly large shapefiles (one has about 30k records, the other is the census blkgrp.shp from ESRI Data&Maps, so about 211k records) within a python script for the past year or so without any issues.  Recently (within the past week) it has not been completing the intersect - there hasn't been an error returned, but the tool just gets hung up.  I just tried to complete the intersect between these two shapefiles manually within ArcMap, and I noticed in the results window that the most recent message is "Processing Tiles", but the Percentage at the bottom of the screen is stuck at 0%.

Neither of the shapefiles seem to be corrupt. I'm using ArcGIS 10 (ArcEditor license level) with Service Pack 4 and the most recent patch installed.

I'm at a loss since I've been using this data/tool for awhile with no problems, and I'm not sure what's causing the tool to fail. Any insight/suggestions on what to try is appreciated!
Thanks : )
0 Kudos
2 Replies
MathewCoyle
Frequent Contributor
How is your memory usage during the processing? Have you tried running it using the ONLY_FID Join Attributes value?

I'd try a Repair Geometry on both feature classes.

When you run the intersect, try setting a larger XY tolerance in your environment settings. 1m should be a good test.

If that doesn't work, try running it from the python window.

If that still doesn't work, try exporting them both to a FGDB and repeat the previous steps.

Final attempt, try intersecting using a subset of the data.

Still doesn't work? Contact Esri support.
0 Kudos
DanielSheehan
New Contributor II
Yeah, I had a large bunch of NYC background data and ran into a similar problem, needed to #dissolve my features because of overlapping roadbeds and other features. After the #dissolve, couldn't get #intersect to pass 0%. #BadGeometry.

I have a tendency to see bad geometry with file geodatabases and not with shapefiles. Came into this with a LiDAR-derived Tree Canopy layer as well. Can anyone form #Esri comment on why FGDB's have these problems and not shapefiles?

Also, to let you know, my features have Z-values disabled before the intersect.
0 Kudos