how to make a arctoolbox permanent in toolbox list

8566
8
02-19-2011 02:51 PM
ElaineKuo
Occasional Contributor
Dear,

I customized a toolbox based on python code using "Add toolbox" by clicking right under ArcToolbox.
However, when ArcMap was reopened, the customized toolbox disappeared.

Please kindly advise how to make the added toolbox "stay" in the list.
Thank you.

Elaine
Tags (2)
8 Replies
DanPatterson_Retired
MVP Esteemed Contributor
It is possible, see the section on Save Settings and Load Settings in the help file
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//003q0000001m000000.htm
DavidHughes1
New Contributor

I realise this is quite an old thread but I've just tried this (starting from a fresh Normal.mxt file) and it's not worked quite how I thought it would/should. When I right click and select Save Settings > To Default, should that not mean that next time I open ArcMap (10.2.2) it should show the python toolbox I've added straight away? It will appear if I right click and choose Load Settings > From Default. What's the point in it being called "default" if it doesn't load by default?! Surely I've done something wrong!

Cheers for any help.

Dave

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

This is from the 10.3 help Setting geoprocessing environments—Help | ArcGIS for Desktop which should be the same as for 10.2.x for the most part.  check by setting it in arccatalog and in arctoolbox, just in case they aren't talking.

0 Kudos
DavidHughes1
New Contributor

Cheers for the quick response Dan. Still no luck in ArcMap. I can see the python toolbox under "My Toolboxes" in ArcCatalog but I still have to either manually add it in ArcMap each time or sometimes right clicking and choosing Load Default works. It's behaving like this on three computers that I know of - haven't tested any others but I'm fairly sure it'll be the same.

I was toying with this method to create an installer for the toolbox for a while but didn't really get anywhere... ArcGIS Help (10.2, 10.2.1, and 10.2.2). The script files seemed to be copied to the Lib/site-packages folder correctly after running the installer but still weren't loading in ArcMap by default. Was this along the right track?​

The only "fix" I've managed to get to work so far is to save an mxd file with the toolbox loaded and work from this "template" each time. Not ideal! Whilst I'm not too bothered by this personally, it's a toolbox I've written to speed up various repetitive processes done by many members of staff in my office. I could do with a script that just loads first time without needing people to load/click certain things.

Cheers,

Dave

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

actually, the way you propose, is what I do by default...never even thought!!   It saves me filling in a lot of stuff for the project properties section.  ie author name is done, fix the date, change a few keywords, default toolboxes are already there and the like.  Also, environment settings can be guaranteed to be set and saved with the project.   If fine it more useful that that default geodatabase thing.

0 Kudos
MJChurchill
New Contributor III

You can't do this directly from ArcGIS Desktop or Catalog but if you have administrator privileges on your computer you can get around it.

Do exactly what you would do to create a new toolbox for a map document, saving the new toolbox somewhere on your computer where administrator access is not needed.

Then just browse to the location where you saved the new toolbox and move it to the ArcGIS installation Toolboxes folder. (On my computer this is in C:\Program Files (x86)\ArcGIS\Desktop10.4\ArcToolbox\Toolboxes).

Toolboxes in this folder appear by default in new .mxd documents.

As I said, you need to be an administrator on the computer your using. Otherwise the template method may be the only way to go.

To add scripts to the toolbox, you can either do it before you move it or you need to set the permissions for the tbx file in the Toolboxes folder [Right click on the toolbox, click 'properties', then the Security tab. Click the Edit... button. Under 'Group or user names', select 'Users...' or your own user name (something other than 'SYSTEM' or 'Administrators...'.  Finally, under Permissions for Users, check the Full control box, then OK out]

M.J.

ValCannon2
New Contributor III

This is a terribly inconvenient work-around. I hope it gets fixed in a future GIS application.

0 Kudos
DanaNolan
Regular Contributor

I have a few template maps which I use for new maps. But, I have been slowly converting most of my maps that I plan to reuse to the Save All Customizations to the document setting. This is under Customize/Customize Mode/Options tab. Once you set that and save the map, it will never be affected by other templates or other maps you open up. This has prevented maps reverting to troublesome defaults, such as setting background geoprocessing on or pointing to an old or nonexistent scratch database, with out my knowing they are on. One on my major new tricks for this year.

One disadvantage is that if your map develops issues requiring resetting your template, there are a few extra steps involved in doing this.

0 Kudos