Geometry is not M-aware

6522
12
05-25-2013 04:14 PM
TRaabis
New Contributor
Hello All,
I am in desperate need of help.  I have been trying to run Polygon Neighbors on a large data set but I am constantly getting the following error: The geometry is not M-aware.  After reviewing and trying many different suggestions on an archived ESRI forum I am still running into the error.  This tool has worked for me in the past so I'm stumped as to why it is not working now.  Here is a list of the things that I have tried to solve this error - none of which have worked:
- ran multi-part feature to single part feature
- cleaned the data set
- converted the feature class to a shapefile
- converted the shapefile and feature classes to a new shapefile and feature class and disabling the M value in the environment
- clipped the dataset to a smaller size
- tried running the tool in ArcCatalog and ArcMap 10.1 Basic
- rebooted ArcCatalog and ArcMap and my computer

If anyone has any suggestions it would be greatly appreciated.  Thanks in advance.

Teresa
0 Kudos
12 Replies
DanPatterson_Retired
MVP Esteemed Contributor
Ok I am confused...in one of your steps you disabled m-aware and now you are getting the m-aware error/warning...have you tried omitting that step to see if it goes away???
0 Kudos
TRaabis
New Contributor
Hi Dan - thanks for the question.  Sorry if my post was not clear.  The first time I ran the tool I received the error message afterwhich I tried the different solutions listed in my first post.  I tried different combinations of the solutions as well (for example, tried running the tool in ArcCatalog on both the feature class and the shapefile, and I tried running the tool on the shapefile where the m-values were not disabled and where they were disabled (both in ArcCatalog and ArcMap), etc, etc). 

Basically I have not found a solution or combinations of solutions that will get the tool to run without getting the error message.  The other strange thing is that I have checked all of the feature classes and shapefiles that I am running through the tool and none contain M-values.
0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor
At a loss.... tech support may resolve this if you provide them with sample data and your workflow ... good luck
0 Kudos
LukeWebb
Occasional Contributor III
Hello All,
I am in desperate need of help.  I have been trying to run Polygon Neighbors on a large data set but I am constantly getting the following error: The geometry is not M-aware.  After reviewing and trying many different suggestions on an archived ESRI forum I am still running into the error.  This tool has worked for me in the past so I'm stumped as to why it is not working now.  Here is a list of the things that I have tried to solve this error - none of which have worked:
- ran multi-part feature to single part feature
- cleaned the data set
- converted the feature class to a shapefile
- converted the shapefile and feature classes to a new shapefile and feature class and disabling the M value in the environment
- clipped the dataset to a smaller size
- tried running the tool in ArcCatalog and ArcMap 10.1 Basic
- rebooted ArcCatalog and ArcMap and my computer

If anyone has any suggestions it would be greatly appreciated.  Thanks in advance.

Teresa


Try the repair geometry tool if you haven't already.
0 Kudos
RobO_Loughlin
New Contributor II

Hi Teresa,

This may be a long but did you find a solution to this or can you even remember!? I am having the exact same issue and I'm at a loss!

Tried all of the suggestions I found but still getting this issue?!?!

Thanks

Rob

0 Kudos
GillianHolloway
New Contributor

I am also running into this problem. Has anyone found a solution?

Thanks,

Faye

0 Kudos
CorySmith3
New Contributor

I had the exact same error ("geometry is not m aware") with the program ("Polygon Neighbors") and weirdly this thread was the only one I found online about it. I was also able to fix it for me, although I don't know how general my solution is since it has nothing to do with the error message.

 

Anyway, here's what worked for me. Instead of listing the output directory as the one I wanted, I left it as the default ("C:\Users\corydeburd\Documents\ArcGIS\Default.gdb\WestBengal_ACon_PolygonNeigh2" for my folder system & specific file). I was then able to get the table. So, it had nothing to do with "m awareness" for me.

 

For some reason, there was an unspecified error when making this dbf so I just had to copy the whole thing (select all & Ctrl+Shift+C).

 

Godspeed all others coming to this thread with the same problem, I truly hope my solution works for you as well. I don't know why ArcMap is so ridiculously buggy, this sh** cray.

0 Kudos
AylinAkkaya
New Contributor

Thank you so much i tried for two days to figure out this problem and loosing it for good.

When i read comment, i wouldnt think it would work but here we go,

Thank you, this was the only option that actually worked for me,

0 Kudos
JustineAllpress
New Contributor II

I did what Cory suggested when I was having the same issue with Polygon Neighbors and it actually worked! No idea why, but give it a try!