Feature Compare tool -- why is it comparing geometry?

3429
5
03-13-2015 01:09 PM
JonathanBailey
Occasional Contributor III

Hi,

I'm trying to compare 2 different versions of a point feature class. I kept getting warnings indicating that the SHAPE was different, regardless of how large I set the XY and Z tolerances. So, I changed the compare type to ATTRIBUTES_ONLY, and I still get warnings indicating that the SHAPE field is different. Why is this happening?

Following are tool inputs and output messages:

Thanks,

Jon.

0 Kudos
5 Replies
ChrisSmith7
Frequent Contributor

Can you try omitting the field?

ArcGIS Help 10.1

JonathanBailey
Occasional Contributor III

Hi Chris,

Yes, omitting the Shape field works. Why?

However, I would like to compare the shapes -- but it seemed that the results that I was getting were wrong, based on the tolerances that were defined.

Thanks,

Jon.

ChrisSmith7
Frequent Contributor

It's been awhile since I've used feature compare. It may be related to your projection (looks like GCS since the cluster is set in decimal degrees). What happens if you run it again with the dataframe using a projected coordinate system, like state plane for your research area, and set the cluster tolerance in feet?

0 Kudos
ChrisSmith7
Frequent Contributor

Oops, just realized state plane probably wont work for your area of interest! Maybe UTM will work?

0 Kudos
JonathanBailey
Occasional Contributor III

Hi Chris,

I tried that, but it still doesn't seem to be producing the correct results. I changed the map projection to UTM, re-ran the tool, increased the tolerances to well larger than any differences that are present, still producing the same result. I also tried in ArcCatalog, with the same result.

I also notice that if I check the Continue Comparison result, the tool generates more warnings -- for different features. I was under the impression that this option would create multiple warnings for the same feature, if warranted, but perhaps I misunderstand that.

Thanks,

Jon.

0 Kudos