Extract Data Task errors

2703
2
Jump to solution
04-14-2014 01:25 PM
jasonlouis
New Contributor II
Hi'ya,

I am trying to run the extract data task.  I have published my map.  I fill in the values with a raster layer.  It returns with 2 errors...

Failed to clip layer <layer name>
Extension is invalid for the output raster format.  Please verify that the format you have specified is valid.

I have tried only clipping an area of interest and adding that layer, not clipping, or clipping and adding a raster.
I have tried changing the name of the output and changing the extension, including .tif, .img, .zip and leaving it blank.  The output defaults to a .zip format.  I have tried just using the default value.  Nothing seems to resolve this.

I am open to suggestions as to what I can try.  I dont really care about the output.  All I need is for this to run once so I can publish it to arcserver.  I wonder if I publish this output with a warning if it will work? It does say completed successfully, even though I cant view the file. 

Any help is appreciated.  Thank you, in advance.
0 Kudos
1 Solution

Accepted Solutions
JimCousins
MVP Regular Contributor
Just a shot in the dark, but some tools are still limited by a past naming convention. Try saving to a directory with no spaces, and no names longer than 8 characters. Also limit your output name to less than 8 characters.
Regards,
Jim

View solution in original post

2 Replies
JimCousins
MVP Regular Contributor
Just a shot in the dark, but some tools are still limited by a past naming convention. Try saving to a directory with no spaces, and no names longer than 8 characters. Also limit your output name to less than 8 characters.
Regards,
Jim
jasonlouis
New Contributor II
Thank you, both.  In the end, I had selected the incorrect option for my file type...repeatedly.  It's so easy to get into a rhythm and not fix what you're doing wrong.  I appreciate your time in answering.