Select to view content in your preferred language

Experiencing "Error 999999: Error executing function" for a simple buffer task

09-11-2014 02:09 PM
New Contributor III

Hey all,

I have a polygon shapefile of a forest extent containing approximately 2,200 forest fragment features that I would like to place a -100m internal buffer on to find the fragment core sizes. The largest forest fragment is about 450,000 ha.

However, I keep running into an "Error 999999: Error executing function" every time I try to run the buffer tool. I tried running the tool with some individual fragments and it seems to work for the smaller ones (around 1,000-2,000 ha). Unfortunately I can't access the log file because I don't have administrative rights.

I have tried making sure the processing extent is correct (I feel like for buffer, the "Union of Inputs" should be a correct option since there's only one input, but I have also specified the extent of the forest shapefile just in case). I have also tried changing the projection--but nothing seems to work. In the end, I have to stop because my computer keeps running out of memory. I have to restart ArcGIS after the first attempt to buffer fails because the second attempt will also fail because there is not enough memory.

Help is appreciated, thanks!

0 Kudos
2 Replies
Esri Notable Contributor

It could be that your have a fragment that is so small that the negative buffer creates invalid geometry.

Also, I've moved your post into the Geoprocessing space. You will get a much better answer here as the GeoNet Help is intended for community help and feedback. You can see more on the community structure, and what topics are under each space from the following documents:

GeoNet Community Structure

ArcGIS Discussion Forums Migration Strategy



0 Kudos
New Contributor III

Thanks Timothy! I'll be honest, I don't think I know how to post anything correctly in this forum haha. I usually just go to the "Create" tab at the top, then go to "Discussion" and post a discussion. Where it posts to, I never know.

In response to your answer, I would think that is the case, but if the buffer causes no geometry, the feature is usually just skipped. I reran the same -100m buffer using a simplified version of the forest extent, and the process worked. It skipped several thousands of tiny forest fragments in the process, but that was expected.

The original forest extent shapefile I was working with (and was mentioning in my first post) was one that I created by converting the original raster to a polygon and UNCHECKING the simplify polygon box, because I wanted the polygon forest layer to mirror the original raster as close as possible. Maybe it's possible that the shapes are just too complex for ArcGIS to handle a negative/interior buffer? It was able to use the unsimplified forest extent to do a +1km buffer, however.

0 Kudos