Euclidean Distance Tool Error

07-04-2012 04:17 AM
New Contributor III

For my work I've been using the tool Euclidean distance under Spatial Analyst tools. I used it yesterday and it worked fine but now when I try to run in I get a generic Error: 999999. Usually the error message will help me get around my issue but this one doesn't tell me much. I really have no idea what I'm doing wrong.

I'm trying to create a raster showing distance from rivers and using the land as my processing extent and I'm making sure I delete the output from the attempts so I'm not trying to overwrite anything.

0 Kudos
4 Replies
MVP Legendary Contributor
change your output path so that it doesn't contain spaces or other unsavory characters and see if that helps.  Also output filename should be 13 characters or less
0 Kudos
Occasional Contributor III
Try adjusting the output cell size. Also try not providing the output cell size.
0 Kudos
New Contributor
Hi Andrew,
I noticed a couple times in the results messages the error: "Failed to open raster dataset". This makes me wonder if there is a problem with your rivers input file. If it is a raster, make sure it is integer type.

If this doesn't work, and you correct the file and path names as Dan Patterson suggests... my guess is that it is probably a problem with the coordinate system. Judging from the default cell size I assume you are using a lat/long coord-system, so try projecting toUTM or another Cartesian type and try again.

Hope this helps,
0 Kudos
New Contributor III
Thanks for the help guys.
Not sure what the problem was but when saving the output eucidean distance rasters in a geodatabase rather than a regular folder my model works.

My only issue now is that i'm not sure which type of measurement is being used in the output. I need to have it in meters and right now it is in some sort of interval where 1 equals a distance well over 100km. I was hoping that by setting my data frame properties to meters that it was create the out raster values in terms of meters but it doesn't seem to work.

0 Kudos