Error DescribeData: Method areaFieldName does not exist

360
7
04-20-2018 02:46 AM
AzimjonSayidov
New Contributor II

Hello all.

I am trying to Increase Polygon Area using "Increase Polygon Area" Tool in the "Production Mapping Tools" in ArcGIS 10.6, which is returning the following error: DescribeData: Method areaFieldName does not exist.

I added a new field and calculated (Calculate geometry) area and set the projection, but no luck so far.

Is there any idea how can this error be fixed?

Thanks in advance.

Azim.

0 Kudos
7 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Is this a featureclass or a shapefile?  Open the table and see if a Shape_Area field exists.  The message suggests that a field wasn't found and since this tool doesn't create new files but modifies existing ones, something is missing

Here is the link to the tool if others are looking

http://desktop.arcgis.com/en/arcmap/latest/tools/production-mapping-toolbox/increase-polygon-area.ht...

0 Kudos
AzimjonSayidov
New Contributor II

Thanks for the response.This is a shapefile with has "AREA" field, however, I did calculated area as a new field as well by Calculate geometry. Yes, this tool does not create new output, but edits the existing one.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

as suspected that is an Area field not Shape_area. I don't have the production toolset, but could you bring that shapefile into a geodatabase.  It will then have a shape_area field.  You would be best suited to see if you are supposed to use shapefiles with the extension or whether they recommend featureclasses in a geodatabase.

And... it looks like there is a join on the table or is that a shapefile and you have saved the join to make it permanent?

Your FID and FID_1 numbers don't match up so was this some spatial join?

In short... get a simple file with a simple set of polygons and test on that before you worry about the file you need.  Just want to rule out script errors first.

AzimjonSayidov
New Contributor II

it did work out after i put the files in the geodatabase, however, when I tried to use "Aggregate Polygons" of the same "Production Mapping Tools" it is returning another error. This is quite strange, as this one was working without any issue until now.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

"small_query" did you type that in or is a field?  maybe show the dialog since most people dont have the extension

0 Kudos
AzimjonSayidov
New Contributor II

Nope, I did not type it, it is a field, where I choose "Combine Field" and "Distance" between polygons and "Minimum Area" as an optional field. 

 

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

So I am guessing that the distance is somewhere between your first example and your second?

You are sure that the featureclass is in projected coordinates?

barring that have a look at the code samples in the link

http://desktop.arcgis.com/en/arcmap/latest/tools/production-mapping-toolbox/aggregate-polygons.htm

0 Kudos