ERROR 100014 Summarize Within failed

3147
14
03-08-2023 10:12 AM
MarkBinder
Occasional Contributor

I have a Python script that goes through several steps including using arcpy.analysis.SummarizeWithin(). When I run the script in the Python window of ArcGIS Pro it works just fine. When I run the script in an IDE like Spyder or Visual Studio Code sometimes I get the ERROR 100014 code; and sometimes it works. 

I am completely baffled why sometimes it works sometimes and not others. All of the datasets are the same each time.

Any suggestions?

0 Kudos
14 Replies
DanPatterson
MVP Esteemed Contributor

perhaps  Error: 100014: Summarize within failed (esri.com)


... sort of retired...
0 Kudos
MarkBinder
Occasional Contributor
That doesn’t work.
0 Kudos
PatSmyth
New Contributor III

Did you ever find a workaround for this? Experiencing the same thing: Summarize within run fine in Pro python window; but fails when run in jupyter notebook (clone of pro env) or vscode (same clone of env). Same non-descriptive ERROR 100014 code that has been mentioned in countless other support threads. This is asinine that this tool has so many caveats that have not been addressed in releases of Pro. 

0 Kudos
MarkBinder
Occasional Contributor

Unfortunately, I have not. The really weird part is that some days it works and some days it doesn't. I've spent hours trying to get it to work one day and the next day it runs with no problem. 

I wish I had better news.

DanPatterson
MVP Esteemed Contributor

That is the only reference on the Tech Support to that error message, so perhaps you need to contact Tech Support.  They may have other references that aren't publically reported since they are still under investigation.


... sort of retired...
0 Kudos
KatMcDonald-Miranda
New Contributor

I'm also getting this error, but only when I add a Summary Field to the tool. When I don't add the field, the tool runs fine.

0 Kudos
tschulzke
New Contributor

I seem to have stumbled upon something that I haven't seen addressed in any of my searches online but may help here. Because the "Summary Field" is basically the reason for using this tool, I reluctantly tried @KatMcDonald-Miranda's solution above, but it threw me a new error  (100019) for the "Add shape summary attributes" checkbox. Although this function is supposedly optional (https://pro.arcgis.com/en/pro-app/latest/tool-reference/analysis/summarize-within.htm), when I checked the box for it and re-added the summary field I had removed, the tool finally ran successfully. Again, the irony is that the documentation says both "Summary Field" and "Add shape summary attributes" are optional parameters, but Error 100019 says otherwise and requires that at least one of these "optional" options be utilized (see screenshot below). Going back to the original problem, it seems that Error 100014 has nothing to do with the real reason the tool fails (as we can see in this thread where the path and/or file name length workaround/solution did nothing to fix the problem), rather the "Add shape summary statistics" box must be checked for the tool to run successfully.

Not sure if this is a version issue, but I am running Pro 3.1.1 and never encountered this problem when using the "Summarize Within" tool in earlier versions of Pro.

tschulzke_2-1689706663564.png

OrrGvili
New Contributor III

cant make it work with script  it run fine in pro 3.1.1

but failed when run with pyton script. 
after successful run in pro i copyd the python command  and try to run it with the script   still get the ERROR 100014

0 Kudos
SageGrouse
New Contributor

I was getting this error, but the solution was to define the projections on my input Feature Classes.

0 Kudos