Don't add model parameter to map

102
0
07-22-2020 12:46 PM
AaronWorthley1
Occasional Contributor II

I have a very simple modelbuilder model that I use to export feature class(es) to a .dwg CAD file. The model just defines the output coordinate system and output type without having to manually select it.

My issue is that the output CAD layers (point, polyline, polygon, multipatch, etc...) are always added to the map. I don't need or want them added and it just makes extra work to select and remove them

Is there any way to have a model parameter (Output CAD File in this case) that does NOT get added to the map on a single model without unchecking "add geoprocessing output to map" for ALL geoprocessing tasks in Options/Geoprocessing? Most of the time, I want model outputs added, just not here.

I wrote a little piece of python code for the Calculate Value tool that finds and removes those layers, but the layers don't seem to get added to the map until AFTER the model has finished running. I've tried with a time.sleep delay and using a submodel...but although the code runs, neither remove the CAD layers when running the tool. The code works fine on it's own, just has no effect in the model.

Other ideas or workarounds to forcing a model to not add output parameters?

0 Kudos
0 Replies