Clipping slows down

979
6
04-29-2017 12:30 AM
FrankLaufer
New Contributor

Hello Everyone,

I have the following problem: I'm trying to clip a quantity of raster data with some shapefiles. For this process I'm using the 'ModelBuilder' (siehe image attached). After starting the process it seems that everything is working very fast. After some time (max. 5 hours) the process of clipping is getting slower and slower so I have to stop it.

Does anybody have a solution to solve this problem?

Tags (1)
0 Kudos
6 Replies
DanPatterson_Retired
MVP Esteemed Contributor

turn on your system monitor to see if you are simply running out of memory.  You may notice an inordinate amount of disk reading and writing as time goes on as well.  

FrankLaufer
New Contributor

Thanks for the help.

When I start the process I can see that the used RAM by ArcMap is getting more and more. Do I have a chance to avoid the increasing use of the RAM by ArcMap?

But there's another thing: Even though I have enough RAM left, the process is getting slower over the time. At first it says about 0,2 sec elapsed time, 20 mintutes later it is about 0,8 sec elapsed time.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

I don't use models often enough, but if you are running out of memory, you might want to ensure that 'add results to display' in the geoprocessing options is turned off.  I don't know if 64 bit background geoprocessing works with modelbuilder or raster clipping... some people swear by it... others, swear at it.

0 Kudos
curtvprice
MVP Esteemed Contributor

How many datasets are you creating? When the number of datasets in a single workspace starts getting large (say above 500) things can start to slow down as the system has to refresh the path on every one and it takes longer. If add results to map is turned on, every output adds a layer to the map (and to memory) which would explain how your ArcMap session keeps growing.

If you are running https://community.esri.com/groups/model-builder?sr=search&searchId=714db1eb-36fe-4e16-97bb-b07f46539... in an open ArcMap session,  you can minimize the slowdown by going to Geoprocessing settings and turning off "add results to map", and also by hitting the pause drawing button at the bottom of the ArcMap window. (Looks like a CD player pause button.)

0 Kudos
FrankLaufer
New Contributor

I'm creating a lot of datasets. About 9000. I will test your solutions and give an answer if it's working or not!

0 Kudos
curtvprice
MVP Esteemed Contributor

Definitely you should try both things: 1) tiling your data into multiple folders and 2) turning off add results to map. Both should help.

0 Kudos