Clip function not performing

1281
5
02-02-2017 04:24 AM
RobertWilliams3
New Contributor III

Hi All, Trying to run a simple extraction of one feature layer via 'clip' of another feature layer. When i run the clip the output still has features outside of the clip feature. Any thought on where i might be going wrong?? I have run 'clip' using the same clip feature on other input layers and it works fine. Thanks

0 Kudos
5 Replies
PanGIS
by
Regular Contributor

Hi,

It might be that you are clipping two feature with different coordinate system, have a look at that.

If this is the problem, try to project them in the same coordinate system.

0 Kudos
RobertWilliams3
New Contributor III

Hi, thanks for the reply.

Both layers have same coordinate system. 

0 Kudos
NeilAyres
MVP Frequent Contributor

So...

Arc version?

What input layers "work" and what don't?

What is the difference between them.

Clip and input feature types and storage, fgdb, shape....

Any errors?

What remains, a picture might help.

RobertWilliams3
New Contributor III

Hi 

I'm using Arc10.3.1

the input layer is a shapefile feature class layer of buildings. The clip layer is a feature class land use layer. The land use layer has worked as a clip on a road network layer but wont on the buildings.

You can see at the top of the extent that the buildings outside of the landuse layer remain following a clip. Thanks.

0 Kudos
ChrisDonohue__GISP
MVP Frequent Contributor

One thing to quickly check on the longshot that it is the culprit is the extent of the clip feature class polygons.  I noticed from your example that the land use layer is symbolized.  It may be that the chosen symbology is hiding the fact that there are land use polygon(s) outside the visual extent shown there by not symbolizing them.  To check this, make a copy of the land use layer in the Table of Contents.  Then set the symbology to Single Symbol and see if the extent is greater than what is currently being depicted.

Chris Donohue, GISP