Buffer error

9831
7
05-18-2010 10:49 AM
JanetBrewster
Occasional Contributor II
I'm having problems buffering a particular line file (local roads, half and quarter mile buffers) -- I keep getting:
ERROR 999999: Error executing function.
An error occurred during the buffer operation
Failed to execute (Buffer).

I've been able to buffer other line files using the same distances, and not sure what makes this one different. I've tried selecting parts, in case I was trying to buffer too many lines, but I keep getting the error.  I'm using 9.3.1

Any thoughts? Thanks -
0 Kudos
7 Replies
KevinHibma
Esri Regular Contributor
Hello,

Is it failing immediately, or after some time of attempting processing?
Approximately how many records are you buffering?
Are the features inside a fGDB, shapefile, SDE... or?
0 Kudos
curtvprice
MVP Esteemed Contributor
JC, You may want to check out these KB articles:

Problem:  Certain geoprocessing tools will not execute or work unless the user is an administrator
http://resources.arcgis.com/content/kbase?fa=articleShow&d=29559

HowTo:  Redirect where ArcInfo Workstation and/or ArcGIS
writes temporary or scratch files during processing

http://resources.arcgis.com/content/kbase?fa=articleShow&d=11835
0 Kudos
HeatherHainsworth
New Contributor
Did you ever find a solution to this I am having similar problems.

Right now if I create my buffer with rounded corners I get that error message but if I create it with Flat corners it is successful.

I am using a workgroup licenses SDE SQL Express database, the feature class is a line it has 1281 features in it and I am trying to dissolve any of those features that are joined.

Also I am using ArcGIS 9.3.1

Just curious if you ever solved your problem and what you did to solve it?
0 Kudos
ChrisSnyder
Regular Contributor III
The issue you are having may be cause by the Dissolve option in the Buffer tool. The ESRI dissolve algorithm is prone to run out of memory if the geometry is large/complex (roads and streams are typical offenders). Try running the tool not using the dissolve option. Does it work then? If you are interested, I wrote a script that may help. It isolates interconnected features (features that overlap), assigns them a unique "spatially overlapped" identifier, and then includes the unique identifier as one of the dissolve items. Takes a while sometimes, but has never failed me.
0 Kudos
JeremyFreund1
New Contributor II

Any way that I can get your script? I am having a similar issue.

0 Kudos
HeatherHainsworth
New Contributor
I would love to take a look at your tool, as you are right if I ask for rounded corners and do not set the tool to dissolve it does run.

I even tried letting it create the rounded polygons hoping I could dissolve it in a seperate step but it seems to just keep running and running and running.

Thanks
Heather
0 Kudos
ReidMcLean
New Contributor
Hi, I am having the same problem trying to buffer a larege wetlands dataset.  I would love to try your connector script put when I click on the zip file it get an error saying I do not have access permission on the server.  Would you be able to email me the zip file?
0 Kudos