Blank ArcToolBox: no tool at all!  ArcGIS 10

1038
3
04-25-2012 01:42 AM
SylvainPichon
New Contributor
Hello,

ArcGIS 10 was setup on my computer last week, but since then, the ArcToolBox is blank.
I mean there are no tools displayed in the window, just "ArcToolBox" with its icon at the top, nothing else.
[ATTACH=CONFIG]13799[/ATTACH]

I tried to right clic on it to add tools, but it doesn't work. When I find tools by searching them, they don't work neither: nothing happens when I clic on it.

I found on forums that it might work by deleting the ESRI folder in the registrery and in my doccuments and settings' user account, but not for me!

I have in my computer (everything in french): Windows XP SP3, ArcGIS10 SP4, and IE8 as I understood it can be linked with this last software.

Anyone already met this issue?

Any help would be greatly apreciated!

Sylvain
0 Kudos
3 Replies
ShitijMehta
Esri Regular Contributor
It could be a bad install. Uninstall and reinstall ArcGIS. Do a complete install and not a custom one.
0 Kudos
JakeSkinner
Esri Esteemed Contributor
Try renaming your ESRI folder in your registry:

Start Menu --> Run --> type "regedit" - Expand HKEY_CURRENT_USER folder - Expand Software folder within HKEY_CURRENT_USER - Rename the ESRI folder to ESRI_OLD
0 Kudos
MaximSilin
New Contributor III
Had similar issue. Upon investigation it turned out that some folders under "C:\Program Files\ArcGIS\Desktop10.0\" (Including the 'ArcToolbox') were marked as HIDDEN in Windows, preventing ArcGIS application from seeing the contents. Right-clicked on the 'ArcToolbox' folder, opened Properties and unchecked the 'HIDDEN' parameter. After that the ArcToolbox got populated. Not sure how the folders became hidden in the first place...