ArcGIS10SP5: Add Join (ModelBuilder) still doesn't work?

649
1
10-17-2012 01:46 AM
PeterWilson
Regular Contributor
It seems that the Add Join still doesn't work in ModelBuilder. I can take the results produced by my model (ModelBuilder) feature classes and tables and perform the join within ArcMap and produce the table that I'm looking for, yet ModelBuilder will not reproduce the join. Fields are dropped during the join and the output join is everything but what you'd expect. I'm joining multiple feature classes (3 Feature Classes) and one table to produce a single table of summary results. I can't use ArcGIS 10.1 as I'm currently still relying on HEC Geo-HMS as part of my model. I can't unfortunately upload my data as its way to large a study area. My model uses general ArcGIS tools as well as ArcHydro and Geo-HMS all function as expected except Add Join. This is extremely frustrating that ArcGIS can't perform joins correctly.

Regards
0 Kudos
1 Reply
DuncanHornby
MVP Frequent Contributor
Peter,

Having looked at the model (pretty impressive!) and the Help on AddJoin I was wondering if you should put a Make FeatureLayer\Table before the AddJoin tools?

Just an idea?

Duncan
0 Kudos