"invalid index grid size" error when trying to digitize using feature set variable

1324
2
05-14-2013 03:35 PM
CharlottePeters
New Contributor III
Hi,
I'm having a hard time understanding why I'm getting the attached error when using a feature set variable. I created the attached model in ArcGIS 10.1, sp1.

I want the user to digitize a new polygon and have it appended to an existing feature class called "proj_1600loc_poly" which has a feature template for editing. In the model, the new polygon variable is a feature set data type with the schema imported from an existing dataset within the project ("proj_1600loc_poly") or from its source location. When I open the model as a tool from ArcToolbox, I see "Model:: New Project" in the input parameter field and underneath the field I see the correct symbology needed to digitize the polygon. I digitize a polygon, but get the attached error when it tries to save (or append?) the new polygon. I tried to change the Output Spatial Grid environment settings while in the tool's dialog and then within the model in model builder, but I get the same error.

I didn't have this issue with the model when it was used in ArcGIS 9.3.1. I recreated the 9.3.1 model for 10.1. I don't know what other settings to consider. I've looked at this common errors link http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//001t00000012000000.htm and the help section on interactive controls.

Thanks, Charlotte
0 Kudos
2 Replies
by Anonymous User
Not applicable
Original User: chane

Hello Charlotte

I am having the same problem in ArcGis Desktop 10.1 sp1. Did you find a solution?

Thank you very much.

Sebastián.
0 Kudos
CharlottePeters
New Contributor III
I revisited the issue again today after putting it on hold and this is what I found out.
Still received the invalid index error but realized the feature being digitized was being put into a temp in-memory FILE geodatabase. I had set the schema for my feature set's variable to a PERSONAL geodatabase and the append target was to a PERSONAL geodatabase. Don't know if it makes a difference mixing FILE and PERSONAL geodatabase processes, but I didn't get the error when I based the feature set schema and output on a shapefile or FILE geodatabase feature class. So I created a new FILE geodatabase and imported the feature classes from the personal geodatabase. Now I have to deal with the loss the table editing feature. With the old working model, after a feature was digitized the user was able to add attribute values to the fields with the help of domains that I had set up for the feature class. While I can digitize a feature now, I have to edit the table outside of the tool dialog and I don't have the field dropdown lists with the domain values. The table editing feature of the old model is needed to keep data entry consistent among multiple users, but I'll save that for another post.

Charlotte
0 Kudos