Select to view content in your preferred language

Address locator not showing geometry

04-08-2016 08:53 AM
New Contributor III

I am trying to create an address locator for some intersection point data I created. After I create the locator and run it with my input data, it says it matched the ones I expected it to match, but no geometry shows up. When I zoom to an individual point, or to the entire dataset of the geocoding result feature class, it basically zooms out to infinity. It's a single-field locator. I've done this a zillion times.

There is nothing wrong with the reference data set. It's a regular point feature class of intersections, with regular fields, and it shows up just fine in ArcMap and the preview in ArcCatalog. I've even tried making a shapefile version and using that as the reference data set, but it makes no difference.

There is also nothing wrong with my input spreadsheet. It's a regular Excel spreadsheet which I save as a CSV file. In fact, I know there is nothing wrong with it, because when I try to use it as an input file using a different address locator I made (which uses a different point reference data set), it works just fine.

In fact, that latter point is the bizarre part. Using the exact same steps to create an address locator (single field locator, etc) but happening to use a different reference feature dataset, the whole process works just fine. It is only when I use this one particular feature dataset (intersections) that the resulting geometry gets messed up ... but there is seriously nothing wrong with that dataset. As I said, it's a regular feature dataset (or shapefile) that shows up just fine everywhere I use it.

I've tried playing around with all sorts of re-naming columns, altering field values, etc., but it makes no difference.

Can anyone think of anything I might be missing?

Tags (1)
0 Kudos
1 Reply
New Contributor III

I just discovered the reason - you cannot use multipoint features as your reference dataset. That creates a few problems, unfortunately.