64bit Background Geoprocessing leads to ERROR 000210

2161
4
11-12-2012 03:48 PM
GraemeBrowning
Regular Contributor
Below are two results from the Python window of ArcGIS for Desktop 10.1 SP1 with 64bit Background Geoprocessing installed.  The only difference (besides changing the output feature class name) is that the Enable checkbox for Background Processing on Geoprocessing | Geoprocessing Options was toggled for the second run.

In the foreground 32bit geoprocessing had no problem writing to my Default Geodatabase but in the background 64bit geoprocessing could not - why not?

>>> arcpy.Buffer_analysis(r'C:\avhome\Data\QLDgeology\LassitersReef_FileBased.gdb\WongaExt','test','2 kilometers')
<Result '..\\..\\Users\\Graeme\\Documents\\ArcGIS\\Default.gdb\\test'>

>>> arcpy.Buffer_analysis(r'C:\avhome\Data\QLDgeology\LassitersReef_FileBased.gdb\WongaExt','test2','2 kilometers')
Runtime error  Traceback (most recent call last):   File "<string>", line 1, in <module>   File "c:\program files (x86)\arcgis\desktop10.1\arcpy\arcpy\analysis.py", line 686, in Buffer     raise e ExecuteError: ERROR 000210: Cannot create output ..\..\Users\Graeme\Documents\ArcGIS\Default.gdb\test2 Failed to execute (Buffer).  
>>> 


The same thing happens for Copy Features and presumably every other 64bit supported tool.

If I write the output to a workspace other than the Default Geodatabase in user documents it works for 64bit background.

I've also tried deleting ..\..\Users\Graeme\Documents\ArcGIS and letting ArcMap recreate the Default Geodatabase but that does not resolve the problem.
0 Kudos
4 Replies
Jay_Gregory
Regular Contributor
I am having this same problem!  Once I installed the 64 bit background geoprocessing, a lot of my scripts started generating the error
ExecuteError: ERROR 000210: Cannot create output.....
What I can't understand is your workaround.  If I'm running a python script outside of ArcMap, how can I use the "Enable checkbox for Background Processing on Geoprocessing | Geoprocessing Options".

Thanks!

Jay
0 Kudos
KevinHibma
Esri Regular Contributor
Jay,

There isn't a checkbox for foreground/background outside the app.
See this blog, it should explain how to run against 32/64bit Python, controlling 32/64bit execution:
http://blogs.esri.com/esri/arcgis/2012/11/12/python-scripting-with-64-bit-processing/

Graeme,

I've never seen this behavior. I can't reproduce it, nor has anyone ever reported it. Based on your syntax and data input - it all looks fine.
If you can reproduce it 100% of the time, can you very plainly write out the steps you do to encounter this?
I can't even offer you a suggestion - the error message is pretty straight forward, but I have no idea why its happening.
0 Kudos
curtvprice
MVP Esteemed Contributor
>>> arcpy.Buffer_analysis(r'C:\avhome\Data\QLDgeology\LassitersReef_FileBased.gdb\WongaExt','test2','2 kilometers')
Runtime error  Traceback (most recent call last):   File "<string>", line 1, in <module>   File "c:\program files (x86)\arcgis\desktop10.1\arcpy\arcpy\analysis.py", line 686, in Buffer     raise e ExecuteError: ERROR 000210: Cannot create output ..\..\Users\Graeme\Documents\ArcGIS\Default.gdb\test2 Failed to execute (Buffer).  
>>> 


This is interesting. I'm wondering if these relative paths for your output workspace are causing a problem for background processing, as the background process may not be as smart about knowing where the current folder is?

Where is your map document located? Is it in your Documents folder?
0 Kudos
ErikMartin
Occasional Contributor
I've been having problems with the 64bit background geoprocessing if I run the script in ArcMap and have any of the layers involved in the script in the dataframe.  When I remove everything from the MXD, the script will work.
0 Kudos