Select to view content in your preferred language

X-ray for ArCatalog error

04-12-2021 06:53 PM
New Contributor II

I keep getting this error when trying to export GDB to XML workspace.  I know X-ray Add in works because i used it for other GDBs.



I also tried exporting the GDB to XML workspace (Schema Only) first, then used X-ray tool to open it, then i get the following errors.  Any suggestions.


0 Kudos
1 Reply
MVP Esteemed Contributor

The actual path may help and how it was entered.

I tried to emulate using an abbreviated version and I got errors because it wasn't raw encoded.  Spaces in paths cause issues amongst other things.

p = "C:\Users\moteo\D\D D T\F.xml"  # --- just keeping the first letter mostly
  File "<ipython-input-16-b13bd135476b>", line 1
    p = "C:\Users\moteo\D\D D T\F.xml"
SyntaxError: (unicode error) 'unicodeescape' codec can't decode bytes in position 2-3: truncated \UXXXXXXXX escape

p = r"C:\Users\moteo\D\D D T\F.xml"  # ---- now raw encode the path

'C:\\Users\\moteo\\D\\D D T\\F.xml'

... sort of retired...