Select to view content in your preferred language

Why do polygons transform when appending from File Geodatabase to SDE?

02-27-2017 12:58 PM
New Contributor

I realise that the append tool is supposed to project your data as needed, but when I am using append it is actually changing my data in different ways.

To start I have a File Geodatabase with feature classes that are points lines and polygons.  The feature dataset holding the feature classes is projected to NAD 83 UTM zone 10N

I also have an SDE instance which contains feature classes that are points and lines and polygons.  The feature dataset holding the feature classes is geographic coordinate system NAD 83 CSRS.

When I append from the file geodatabase the following things happen:

1) my polygons generalize and no longer hold the same shape

2) my lines change and become jagged and more complex than they were before

Here is a screenshot of the lines and polygons, the lines are exactly the same as the borders to the polygons:

After appending the geometry into SDE here is what it turns into what looks similar but has changes like this:

The lines no longer match the boundaries and the boundaries have been generalized.

So my question is Why?

I have tried the following, all with the same effect.

1) tried copying and pasting within the Arc editing environment, transforms the polygons and lines in the same way.

2) re-projected the data first into geographic (successful and no transformation apparent on the data) and then appending it into SDE.  same problem occurs with the polygons and lines.

3) tried copying everything into a new geodatabase then appending from it into SDE and same problems with the polygons and lines.

4) checked my tolerances on the input (1mm) and on the output (0.000000008983153 degrees), so nothing going wrong there.  both are at a millimeter tolerance.

So what am I missing here?  What could the issue be.  I've already loaded over 80 maps into this dataset without issue from the same coordinate system, so what's going on in the background that is causing this.


ArcGIS 10.2


Oracle backend

Any help on this is appreciated,

Sean Eagles

GIS Technologist

Natural Resources Canada

1 Reply
New Contributor

5+ years later, wondering if a solution was ever discovered for the issue?

0 Kudos