Upgrade Geodatabase issue

484
5
Jump to solution
01-31-2018 03:16 PM
Highlighted
New Contributor III

Hi everyone, 

I am attempting to Upgrade Geodatabase and the following error prevents the upgrade.

"Connected RDBMS instance is not setup for ST_GEOMETRY configuration.You must copy the latest ST_GEOMETRY library to the PostgreSQL software location"

The GDB was created a couple of years ago using ArcMap 10.3.1,  very recently ArcMap was upgraded to 10.6 

PostgreSQL 9.3.5 is running on Windows Server 2012 R2

The original st_geometry file exists in PostgreSQL lib folder.  Since the error message suggests the latest ST_GEOMETRY file needs to be copied, I've tried copying the files from DataSupport folder in Postgres 9.4, 9.5, 9.6 but that wouldn't even allow connections to be made.

Also the libeay32.dll, libpg.dll,libintl-8.dll and ssleay32.dll files are in the intended location.

Any ideas any help will be much appreciated

Best regards,

Pawel

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Regular Contributor

You did kind off answer the question yourself..

ArcMap was upgraded to 10.6

PostgreSQL 9.3.5 is running on Windows Server 2012 R2

I've tried copying the files from DataSupport folder in Postgres 9.4, 9.5, 9.6

As you can see, the ArcGIS 10.6 Database Support does not have any 9.3 folder. The reason being, PostgreSQL 9.3.x is not a supported database for ArcGIS 10.6.

PostgreSQL database requirements for ArcGIS 10.6—System Requirements | ArcGIS Desktop 

To upgrade any further than 10.3.x, you will have to upgrade the version of PostgreSQL.

PostgreSQL database requirements for ArcGIS 10.4.x—System Requirements | ArcGIS Desktop  (Needs atleast PostgreSQL 9.3.10)

PostgreSQL database requirements for ArcGIS 10.5.x—System Requirements | ArcGIS Desktop  (Needs atleast PostgreSQL 9.3.13)

View solution in original post

5 Replies
Highlighted
MVP Regular Contributor

You did kind off answer the question yourself..

ArcMap was upgraded to 10.6

PostgreSQL 9.3.5 is running on Windows Server 2012 R2

I've tried copying the files from DataSupport folder in Postgres 9.4, 9.5, 9.6

As you can see, the ArcGIS 10.6 Database Support does not have any 9.3 folder. The reason being, PostgreSQL 9.3.x is not a supported database for ArcGIS 10.6.

PostgreSQL database requirements for ArcGIS 10.6—System Requirements | ArcGIS Desktop 

To upgrade any further than 10.3.x, you will have to upgrade the version of PostgreSQL.

PostgreSQL database requirements for ArcGIS 10.4.x—System Requirements | ArcGIS Desktop  (Needs atleast PostgreSQL 9.3.10)

PostgreSQL database requirements for ArcGIS 10.5.x—System Requirements | ArcGIS Desktop  (Needs atleast PostgreSQL 9.3.13)

View solution in original post

Highlighted
New Contributor III

Thanks Asrujit, somehow I managed to miss this important piece of the puzzle.

Hopefully won't encounter any snags during the Postgres upgrade.

Highlighted
Esri Frequent Contributor

Make sure that you have Visual Studio VC++ 2017 installed on the Windows PostgreSQL server:

For PostgreSQL on Windows, you'll need the latest Visual Studio VC++ 2017 installed on the PostgreSQL instance machine. See https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads for more information.

PostgreSQL database requirements for ArcGIS 10.6—System Requirements | ArcGIS Desktop 

--- George T.
Highlighted
New Contributor III

Thanks for the tip, George.

Reply
0 Kudos
Highlighted
Occasional Contributor

have been trying to create a GDB on Postgres, copying st_geometry (C: \ Program Files \ PostgreSQL \ 9.6 \ lib) and I got an error from library latest. The solution was to install VC ++ 2017  Thanks George

Reply
0 Kudos