Select to view content in your preferred language

Upgrade Enterprise Geodatabase to or higher in AWS RDS for PostgreSQL 11.14 with PostGIS 3.1.4

03-29-2022 12:40 AM
New Contributor

I am having issues around upgrading Enterprise Geodatabase in AWS RDS for PostgreSQL 11.14 with PostGIS 3.1.4. The current Enterprise Geodatabase version is 10.7.1, and upgrading to higher versions. I ran upgradeGDB geoprocessing tool by using arcpy from the following options and none of them worked:
(1) ArcGIS Pro 2.8 and 2.9
(2) ArcMap 10.8.2
(3) ArcGIS Server 10.8.x via geoprocessing tool
The errors returned from (1) and (2) say that: "A user with dbo privileges is required."
The user is "sde" user for this database, and it has "rds_superuser" box ticked in PgAdmin. I also re-granted all permissions as possible to this user, and tried again.
The error returned from the option (3) says that: "Connections\ does not exist or is not supported."
Have you got something similar to this? How did you resolve? Thank you in advance for your comments.

0 Kudos
3 Replies
MVP Esteemed Contributor

A couple years ago, we were having significant issues with our RDS instance. We actually moved our data to its own EC2 instance, and haven't looked back. It's a bit more hands-on for managing and maintaining (though, not a whole lot), but it's cheaper than RDS, and we've got total control over the versions and extensions.

A bit of a drastic step, and maybe not what you're looking for, but I thought I'd mention it.

- Josh Carlson
Kendall County GIS
New Contributor

That is an interesting idea. Thank you very much for mentioning it. There will be a heap of admin work involved, but we can take full control over the database. The cost comparison is another interesting thing.

0 Kudos
New Contributor II

Hey @jcarlson : would you mind sharing your config for the database on the EC2 instance? We are seeing abysmal performance in our AWS PostGreSQL RDS and are looking for better options

0 Kudos