Select to view content in your preferred language

Unable to upgrade geodatabase

823
2
06-05-2022 05:57 AM
Labels (1)
sampsongeorge24
New Contributor

Hi All,

I am getting issue while upgrading the enterprise geodatabase from 10.6 to 10.8.1.

Getting error message Could not update server tables and stored procedures.

Also in the log file it shows 

[10:56:54.145] SGA_Param - Open_Cursors: 300
[10:56:54.146] Default value of Open_Cursors: (300) can cause cursor starvation!
[10:56:54.150]
ST_Geometry Schema Owner: (SDE) Type Release: 1007
[10:56:54.151] Instance initialized for ((sde)) . . .

[10:56:54.200] ArcSde is already at an acceptable release:
10.6.1 1
[10:56:54.316] BRANCHES table being created...
[10:56:54.316] BRANCHES table created...
[10:56:54.317] BRANCH_TABLES_MODIFIED table being created...
[10:56:54.317] BRANCH_TABLES_MODIFIED table created...
[10:56:54.318] MULTIBRANCH_TABLES table being created...
[10:56:54.318] MULTIBRANCH_TABLES table created...
[10:56:54.328] ERROR in creating index on TABLE_LOCKS.
Error: -51
[10:56:54.328] DBMS error code: 2158
ORA-02158: invalid CREATE INDEX option

[10:56:54.328] SDE release upgrade not completed(-51).
[10:56:54.335] ERROR installing/upgrading ArcSDE, Error = -51

Unable to figure out why this error is coming.

Regards,

Sampson

0 Kudos
2 Replies
Robert_LeClair
Esri Notable Contributor

The error message looks very similar to this Esri Community post on June 29, 2021.  It looks like there was an SDE schema in place before running the tool.  Might be worth a look.

0 Kudos
GeorgeThomson
Esri Contributor

Hi Robert,

This error seems to be something else which is not the same as he post associated you have mentioned.

ERROR in creating index on TABLE_LOCKS.
Error: -51
[10:56:54.328] DBMS error code: 2158
ORA-02158: invalid CREATE INDEX option

[10:56:54.328] SDE release upgrade not completed(-51).
[10:56:54.335] ERROR installing/upgrading ArcSDE, Error = -51

0 Kudos