Saving Disabled for Attribute Rules

11-27-2019 10:48 AM
New Contributor

I'm creating a feature class to use for data collection and want to apply a number of attribute rules for immediate calculation. I have no trouble defining the attribute rules in ArcGIS Pro, but it will not let me save them. Each time I get the following message:

I've tried this multiple times and cannot get it to work. I'm positive that there are no unsaved feature edits. Please help!

3 Replies
New Contributor III

Same issue here

0 Kudos
Esri Contributor

Hi Adrian, 

My name is Adam, I work with Esri Support, and am working on a open support case @John Gargiulo on this issue. 

We suspect this could be a issue with ArcGIS Pro 2.4.  Or with the location of the Geodatabase. 


-What Version of ArcGIS Pro are you using? if 2.4 Have you tried 2.5?

-Can you identify the full path to the Geodatabase? is that drive local to the computer or on a server?

We appreciate your input, it will help the investigation. 



0 Kudos
Esri Contributor

Hi Adrian,

I wanted to follow up on this topic. The Save option would be disabled because Attribute Rules are "read only" if you have a basic licence. 

Attribute Rules Save button disabled 

Another note here is that at ArcGIS Pro 2.5 the software will present a warning message below. In 2.4 this message was absent. 


I hope this helps, Please "@" me if you have any questions. 

Thanks You,