Rebuilding Index using arcpy taking long time in ArcSDE (SQL Server)

07-12-2015 07:43 AM
Occasional Contributor

Hello All,

I am having a process which truncates and loads 1 million nightly. The feature class has an index applied . After my load completes the process rebuild index and analyzes the feature class. Rebuilding Index and Analyze dataset alone takes 1.5 hr .

I have compressed the database. Tried deleting and recreating the index. No change

I am sure something is not write. Can anyone point me how to identify the issue and solve it


Tags (2)
0 Kudos
3 Replies
Frequent Contributor


There are some helpful recommendations in this thread:

Occasional Contributor

Okay some more notes

I tried rebuilding the index directly in SQL Server it ran in seconds. So I am not sure why it is taking so much time to rebuild index and analyze dataset.

What could impact the performance of rebuilding index and analyze dataset when run through arcpy.

0 Kudos
Esri Esteemed Contributor

Hi Vikram,

Is your feature class registered as versioned?  If it is, the Rebuild Index tool will rebuild the index for the delta (A & D) tables as well as the base table.  If the compress is not successfully clearing the delta tables, this could be causing the long time you are experiencing when building the indexes.

0 Kudos