Python code won't post a version -The specified target version has no edit versions to reconcile with.

06-11-2015 11:50 AM
New Contributor

I keep this message in a log file -

[6/11/2015 9:35:03 AM] Starting reconcile.

[6/11/2015 9:35:03 AM] Warning: The reconcile process was not performed. The specified target version has no edit versions to reconcile with.

After attempting to do a post and reconcile using Python 2.7.1 Arcpy on a SQL SDE 10.0 database using a 10.2.2 client it keeps coming back with this message.  I have copied the python code generated from a toolbox into a python script and it runs but doesn't post the version.  I can successfully post using a toolbox and within an ArcMap session, but not with python residing outside of ArcMap.  I am connecting into the database using an SDE connection and a OS connection but no success.  Any ideas?

0 Kudos
4 Replies
New Contributor III

Hi Linus,

Were you able to resolve this issue? I have seen this occur when the version name and owner do not have the same syntax in the python script as in the Geodatabase Administrator window.  If the owner and name of the version in the Geodatabase Administrator window reads "dbo.DEFAULT" you will need to ensure that the same syntax is used in the script.  "DBO.DEFAULT" or "dbo.Default" would both fail and throw the warning message you are experiencing.  Both the version name and owner are case sensitive.

There is also a bug that has been logged identifying an issue with reconciling using OS authenticated users.

NIM084500 - Arcpy.ReconcileVersions_management() fails to reco..


Occasional Contributor

Hi Linus,

I also kept having this issue with a python script and found this thread while searching for a resolution.

I eventually fixed the error by removing a ".lower()" that was connected to the version names. The ReconcileVersion_management tool is case sensitive and if you your input is changing the version name string capitalization in anyway you will get this error.

Not sure if this will apply to your situation but thought I would share just in case it does



Occasional Contributor III

What I have found is that the version names require a unicode string list u'<version_name>'.  This is what worked for me.  Over that vast canyon and onto the pasture

New Contributor III

I got the same error when I ran the script on Automate reconcile and post operations for sync-enabled data—ArcGIS Help | ArcGIS Desktop 

I made the following changes

  • removed the if statement 
    • if user.lower() in
  • changed 'DELETE_VERSION' in the arcpy.ReconcileVersions_management
  • removed line 62- 80 since it is no longer needed for removal of versions.