Is it possible to fix a corrupt .gdb?

500
1
07-11-2018 08:28 AM
Highlighted
New Contributor

Hi,

I'm working on an urban plan and in the basemap files the administration gave me there was a .gdb folder that I'm not able to open. I'm working on ArcMap 10.2 or QGIS 3.2.

First of all there aren't gdb and timestamps files in the original folder, so ArcMap doesn't recognize it as a db. I can see some files inside from Windows explorer, but nothing in ArcMap. Following some ESRI instructions, I've tried to fix it, but it doesn't work:

  • if I create new gdb and timestamps files, it recognizes it as db (changing the icon in ArcCatalog), but when I try to see the content, ArcMap crashes;
  • if I copy & paste existing gdb and timestamps files, when I try to see the content it shows this error message ":Failed to connect to database. This release of the geodatabase is either invalid or out of data. [Invalid geodatabase release]";
  • if I copy & paste my files in a new .gdb, it shows this error "table has not been found".

Any suggestions?

Thanks,

Herbert

0 Kudos
1 Reply
Highlighted
Esri Esteemed Contributor

Note: also posted at GIS StackExchange

It appears that you were given a corrupt dataset. There are many ways this could happen, including by not paying attention to warnings raised by WinZip or 7Zip during data capture. Recovery from missing files is dependent on which files are missing, but doesn't have good odds if the trivial files have already been tried.

Going back to your data provider will the the fastest and most reliable way to acquire this dataset.

- V