Geodatabase Administration - Locks error Failed to process XML data, possibly due to data corruption

12-07-2020 12:43 PM
Labels (1)
New Contributor

Version 10.6.1 on Oracle

My python script failed due to schema locking error. I tried to view the locks but I got the error:

"Locks error Failed to process XML data, possibly due to data corruption"

I looked at the sde.table_locks table and 2896 tables are locked. I looked at our development server and no tables are locked. The XML corruption really concerns me. Where is this file and can it be fixed?

0 Kudos
4 Replies
MVP Frequent Contributor

Did you do a state zero compression yet?

0 Kudos
New Contributor
Thanks. No I have not.
I followed the links and tried but it looks like a task reserved for the
System Administrator.
I am still poking around looking for the XML associated with the Schema
0 Kudos
Esri Frequent Contributor

I would NOT modify / edit / etc. any XML file that you find. It could cause more corruption of the Enterprise Geodatabase that may not be recoverable.

Are you connecting as the SDE user when looking at the locks?

Are there any other issues in the GDB currently?

This may be best to contact technical support and work with an analyst.

--- George T.
0 Kudos
New Contributor
Yes I contacted ESRI today. Another user had this issue posted, but it does
not look like it was resolved.
0 Kudos