Data disappears when i zoom out

282
1
01-31-2018 09:14 AM
Highlighted
New Contributor

I have a Line feature class (in a feature dataset, in a .GDB).  Just one these 1 of 4 feature classes will only project its data when zoomed in to 1:800.  Only a small fraction of this feature class is affected, it is geograophically close togeather and the editing in the area was done recently.  Almost all of the line types will not display, except 1, as if there is an issue with the definition query settings are wrong, but the problem persisted even when there is no symbology or definition query being used.  The other 3 feature classes function normally.

I have checked the zoom for the feature class.
I have rebuilt the spatial index query.

I have cleared the display cache.

I have tried Exporting to a new GDB.
I have tried repairing geometry.

Is this file corrupt beyond repair?  or is there something else i can try.  The data is still there as i can zoom in and see it... but it will not work at all zoom levels.

Reply
0 Kudos
1 Reply
Highlighted
MVP Regular Contributor

I have tried Exporting to a new GDB.

What was the result of this? Same issue in the new geodatabase?

Did you try recalculating the Extent for that Feature Class? Maybe by mistake a stray line feature was drawn in the FC while editing, which changed the extent drastically..