ArcMap Freezes when connecting to Oracle

09-03-2021 12:07 AM
Labels (2)
Esri Contributor

Hello folks!

I want some advice or ideas to solve this issue ASAP since I have to connect and use the DB in a hurry.

I had originally used ArcMap 10.5.1 and Oracle DB 11g ( The connection was pretty fine, not taking so much time to connect the database and see the contents in it.

Following the security policy updated in my company, the version of Oracle DB was upgraded from to which makes the issue now. I can see the connection file in ArcCatalog, but whenever I double-click the connection it freezes and did not respond for an hour!! After the hour, it shows the contents.


Tried to test different environments, I even did some tests such as, 

- apply ArcMap 10.5.1 patch for Oracle -> still the same

- upgrade ArcMap consecutively from 10.5.1 to 10.6.1 and 10.7.1 -> still the same

- apply oracle instant client and respectively -> still the same (I installed both 32 and 64 bit since ArcGIS Server and ArcMap are in the same machine, and set PATH variable as stated in the technical article)

- upgrade OS version from Windows server 2016 to 2019 -> still the same

- check the firewall settings between the client side and DB side -> nothing blocks and still the same

- compress the oracle geodatabass -> still the same

- remove gp history in database -> still the same


Here are the environment ArcMap is in now.

OS) Windows server 2019

ArcMap) 10.7.1

Oracle) / 10.5.1 (geodatabase version)

ArcGIS Server) 10.7.1


I don't know what causes this thing. Anyone has any idea?

0 Kudos
5 Replies
Esri Frequent Contributor

I would remove the Oracle 11 clients from the machine. Make sure that the 64 bit client is first in the PATH variable.

Then restart the ArcMap client and re-test.

Is the behavior the same from another profile on the same machine? What about a different machine?

--- George T.
0 Kudos
Esri Contributor


I removed the Oracle 11 clients from the machine and restarted the ArcMap. It still has the same issue.

Also, the PATH variables are set as stated in the Esri technical article.

I set up the ArcMap on the other machine and tried to connect to the Oracle Database. There's the same problem as well.

0 Kudos
Esri Frequent Contributor

I would create a technical support case. Testing another client on a different machine and showing the same behavior says to me that it is with ArcMap and that DB.

Are there other Oracle DB's that you can test against?

--- George T.
0 Kudos
Esri Contributor

I have already created the technical support case, but not a specific solution has come up yet. 

Tested with the other client (ArcMap on the other machine) to connect the same DB, but still the same..

Also tested with the other oracle DB,, still the same...

Do you think it is ArcMap's issue or Oracle's?


0 Kudos
Esteemed Contributor

You have updated the GIS client software, but you still indicate that the SDE database is at 10.5.1.  Do you have the ability to upgrade the SDE database to 10.7.1 to match the latest client upgrade?

Do you have all the appropriate patches needed to connect to the Oracle database (I would think tech support would review this item with you)?

0 Kudos