A general error when something is wrong with a Field. [globalid]

03-08-2016 03:33 PM
New Contributor

I get this error when trying to replicate or copy a feature class (actually happens on 3 different feature classes).  The geodatabase is stored in Oracle 11g.  The arcgis client is 10.3.1.  Any ideas why this might be happening and how to resolve?

3 Replies
Regular Contributor

This just happened for me on a GUID field stored in an SDE geodatabase using Oracle (Oracle 12). The geodatabase is version 10.4.1.

I was attempting to copy a feature class from SDE into a file geodatabase stored on a shared network. Any ideas?

0 Kudos
Esri Contributor

We have seen this issue when GUID or GlobalID field is modified by third party application or have wrong type of value inserted/present. This said, your issue may or may not related to the mentioned data error. Still, it is worth a try.

Another option is to copy data in the same enterprise geodatabase with different name and set database trace to find out which objectid or feature has issue or data copy failed.



0 Kudos
New Contributor

I just ran into the same error trying to use arcpy.da.InsertCursor on a Featureclass i created by using arcpy.management.CreateFeatureclass with an SDE layer as a template. Seems like the field assignment got jumbled somehow. I found out that there was something off with the "shape" attributes.
Using this solved it for me:

_Shape_fields =['SHAPE', 'SHAPE.AREA', 'SHAPE.LEN', 'SHAPE.LENGTH', 'SHAPE_Length', 'Shape_Area']    _reduced_field_names = [f.name for f in arcpy.ListFields(fc) if f.name.upper() not in [field.upper() for field in _Shape_fields]]



Then i used the '_reduced_field_names' list as an input with arcpy.da.InsertCursor.

0 Kudos