When building Add-In with ArcGIS 10.3 SDK and Visual Studio 2013, get error "Unable to create .esriAddin"

12-23-2014 10:47 AM
Occasional Contributor II

I have an existing C# .NET Add-In project that I need to migrate from ArcGIS 10.2 to ArcGIS 10.3.  The project was last successfully compiled with the ArcGIS 10.2 SDK and Visual Studio 2010.  It was my understanding that Visual Studio 2013 was supported with ArcGIS 10.3.  When I attempt to build the solution for the project, the .esriAddIn file does not get created and I get the following warning message:

warning : Unable to create .esriAddin; missing ESRI ArcGIS Add-in SDK component(s).

Is Visual Studio 2013 supported with ArcGIS 10.3?  Is there something else I am missing?


Tags (1)
0 Kudos
8 Replies
Occasional Contributor II

I had migrated a project over, things were fine were some time.  Then one day .... had this same issue... restarted, cleaned, rebuilt, even re installed the sdk.... nothing worked. Then went back to it a couple of days later ..... and it was fine ..... not sure what happened but all is well now, I would not be surprised if I saw this error again.  I'll let you know if I find the magic trick that I did

0 Kudos
New Contributor

Just looking into what version of Visual Studio I need for ArcGIS 10.2.2 and found this thread...

How long before Visual Studio 2013 support?

And can see here that it appears to be Microsoft Visual Studio 2010...

System Requirements

0 Kudos
New Contributor

You can create the test project using ArcGIS templates for Visual Studio 2013 and compile it so you would see the add-in and later you load all your forms and class files from old project.

0 Kudos
New Contributor III

After much troubleshooting I figured it out.  I upgraded .Net SDK from 10.2.2 to 10.3 and got the same error.

When you build a project in 10.1 - 10.2.x, VS uses the following file to build the .esriaddin "C:\Program Files (x86)\MSBuild\Esri\ESRI.ArcGIS.AddIns.targets".  After the 10.3 SDK install, ESRI removed this file and replaced it with "C:\Program Files (x86)\MSBuild\Esri\ESRI.ArcGIS.AddIns.11.targets"


The easiest option to fix is to make a copy of ESRI.ArcGIS.AddIns.11.targets file into the same directory and rename it to: ESRI.ArcGIS.AddIns.targets

This way old and new projects will build.

New Contributor II

Alain,  thanks for this information... I was able to fix the problem by editing my .csproj file (with Notepad++)  and changing all of the "AcrGIS.Addins.targets"  entries (I found 3 of them) with "ArcGIS.Addins.11.targets"    I only had one project like this... I would imagine if you had a bunch of projects then using the method you described would be much easier...


New Contributor III

This worked for me as well! Thanks!

Open Project file in notepad,

replaced all "AcrGIS.Addins.targets" with "ArcGIS.Addins.11.targets"

0 Kudos
New Contributor II

Thanks Alain, worked like a charm

Regular Contributor II

Hi William,

Wanted to check in to determine if this is working for you? I would agree with a majority of the people on this thread that it sounds like the problem is with the targets path.

0 Kudos