Replication Errors, New replication won't push changes, and Synchronize changes tool will not work

09-29-2017 06:26 AM
New Contributor

I have been trying to replicate (as Simple One-Way Replication) an Enterprise Geodatabase as the Database owner to an identical Enterprise Geodatabase (database owner) in another folder.  I have edited changes, rec/post, compressed, and then applied the "synchronize changes" tool to the data.  Note, the changes are reflected in the DEFAULT version.  The original replica that was created throws the following error:

Replications do not work in edit sessions but I tried this as well.  This is a new server environment that we are migrating to so I am the only person accessing this data at this point.  I have also used the Distributed Geodatabase toolbar to create another identical "replica".  This new replica runs in the Distributed Geodatabase Toolbar (Synchronize changes) without an error but no changes are applied to the child geodatabase. We have upgraded to ArcMap 10.5.1 and have experience problems with the replication tools in the older environment as well.  I have also tried applying the same Create Replica, then Synchronize Changes tools from ArcToolbox (because these are separate tools).  I get errors with these tools as well.  There errors are as follows:

For Replica:

For Synchronize Changes for the original replica that was created:

Two other things to note:  The old tool throws an error and the error shows up in the ReplicaLog.dat file.  The error is:

<ReplicaMsg time='9/29/2017 8:48:06 AM' type='LOG_MESSAGE_TYPE_ERROR' code='90012' elapsed='0.005000 seconds' method='ReplicaDataSynchronizer::TransferChanges' objectClassName='LandRecords_DW.LANDRECORDS_OWNER.Parcels' replicaName='LANDRECORDS_OWNER.LandRecords_OP2DW'>Objects in this class cannot be updated outside an edit session [LandRecords_DW.LANDRECORDS_OWNER.Parcels] - LandRecords_DW.LANDRECORDS_OWNER.Parcels</ReplicaMsg>

However, the new replica, when run, does not throw an error message, does not add an error message to the Replicalog.dat file, and no changes are pushed through to the child database.  

The error code '90012' falls under the ESRI log errors in the category of Geodata Services.  However, I cannot find any other information about detailed log errors for Geodata Services.  

Any help would be welcome on this issue.  


0 Kudos
1 Reply
Occasional Contributor

Did you have a solution to this error?

0 Kudos