Select to view content in your preferred language

Issue With SystemUI.dll - System.Runtime.InteropServices.COMException

463
0
05-25-2022 07:48 AM
CalebDruckemiller
New Contributor

I'm trying to run an existing .NET app and getting to a part where it's instantiating an "MxDocumentClass" which I believe resides in the ArcGIS.ArcMapUI dll, it loads in that ArcMapUI.dll file, then several others afterwards: 

Loaded '...\ESRI.ArcGIS.Framework.dll'.
Loaded '...\ESRI.ArcGIS.CatalogUI.dll'.
Loaded '...\ESRI.ArcGIS.Output.dll'.
Loaded '...\stdole.dll'.
Loaded '...\Microsoft.VisualStudio.Interop.dll'.
Loaded '...\ESRI.ArcGIS.ADF.Local.dll'.

but then hits:
Loaded ...\ESRI.ArcGIS.SystemUI.dll'.

And I receive: Exception thrown: 'System.Runtime.InteropServices.COMException' in APP.exe
Retrieving the COM class factory for component with CLSID {006B1AFE-C66C-11D0-B94C-080009EE4E51} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

I've tried manually registering the DLL is several ways:

  • Double clicking and registering via the ESRI Arc Registration Tool. This gives me a successful message but is still not registered. 
  • Using regsvr32 through an elevated (administrator) Command Prompt AND Powershell
  • Running sfc /scannow in an elevated command prompt. 

None of which have worked. I am running in x86 Build configuration, so I know that's not the issue either. Does anyone have any ideas? 

Tags (2)
0 Kudos
0 Replies