Failed to Create a Site ArcGIS Server 10.5.1

3807
7
Jump to solution
06-13-2018 11:43 PM
rohannaik
New Contributor II

I am getting the following error when I try to create a site using ArcGIS server 10.5.1 -

<Msg time="2018-06-13T12:27:42,665" type="SEVERE" code="6533" source="Admin" process="5664" thread="14" methodName="" machine="Machinaname" user="" elapsed="">Failed to create the site. com.esri.arcgis.discovery.servicelib.AGSException: java.lang.Exception: java.lang.Exception: The server was unable to access the URL 'https://Machinaname:6443/arcgis/services'. Please check your firewall and security settings. For more information, see the ArcGIS Server help topic Ports used by ArcGIS Server. You can access this topic in the table of contents by navigating to Administering ArcGIS Server &gt; Securing your ArcGIS Server site &gt; Configuring a secure environment for ArcGIS Server.</Msg>

error while creating site

0 Kudos
1 Solution

Accepted Solutions
DanielUrbach
Occasional Contributor II

This may be related to which TLS versions are enabled for the user running the ArcGIS Server service.  It might be worth trying the following:

1) Hold Shift and right-click on the Internet Explorer icon, then choose "Run as different account".  Enter the account that is running ArcGIS Server.

2) Go into the Internet Options > Advanced and confirm that TLS 1.1 and TLS 1.2 are both checked (those are near the bottom of the list)

3) Restart the ArcGIS Server service and try to create the site again

Also, while you have Internet Explorer open as that user, confirm you can hit a website on the internet, to confirm that this user has access to make calls out over http/https.

-Danny

View solution in original post

7 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Rohan,

You can used the attached txt file to check if your ports are open.  Steps:

1.  Rename the file from .txt to .bat

2.  Double-click the .bat file to execute

3.  Enter the server name (i.e. ags1.esri.com)

4.  Enter 1 to check for ArcGIS Server

Ex:

rohannaik
New Contributor II

Hi Jake,

I can see that the ports are closed. Can you suggest how we can enable these ports while creating a site, as I faced the issue while creating site manually and through Chef.

0 Kudos
JakeSkinner
Esri Esteemed Contributor

This may not be a port issue.  I checked my instance, and currently only 6080 and 6443 are open:

It may be best to log a case with Tech Support at this point.

0 Kudos
DanPiciorus1
New Contributor II

Hello, have you solve this issue? I have the same problem with 10.6.1 arcgis server version on an windows server 2008 r2. Thank you, Dan

0 Kudos
JosephDillard
New Contributor II

Anyone have a solution for this issue? I can install 10.3.1 with no issues and create a site. However 10.6.1 will install but gets the same error when trying to create a site. 

0 Kudos
DanielUrbach
Occasional Contributor II

This may be related to which TLS versions are enabled for the user running the ArcGIS Server service.  It might be worth trying the following:

1) Hold Shift and right-click on the Internet Explorer icon, then choose "Run as different account".  Enter the account that is running ArcGIS Server.

2) Go into the Internet Options > Advanced and confirm that TLS 1.1 and TLS 1.2 are both checked (those are near the bottom of the list)

3) Restart the ArcGIS Server service and try to create the site again

Also, while you have Internet Explorer open as that user, confirm you can hit a website on the internet, to confirm that this user has access to make calls out over http/https.

-Danny

View solution in original post

DanPiciorus1
New Contributor II

Thank you, configuring the IE TSLs under the arcgisServer user is the correct approach.

0 Kudos