Check available version of Arcade

69
1
06-02-2020 01:27 AM
Highlighted
New Contributor

Is there any way to check the available version of Arcade from within an arcade expression (attribute rule)?

For example test that $originalFeature is available before trying to use it? (We are using Pro 2.5 but portal 10.7, so different versions of Arcade)

Tags (2)
Reply
0 Kudos
1 Reply
Highlighted
Esri Esteemed Contributor

Hi Andy Egleton ,

To be honest, I haven't seen any functionality to test is something exists depending on the version. Attribute rules are executed on a database level. For instance, ArcGIS Pro 2.5 has support for it when you use a FGDB. However, when you point to an enterprise geodatabase and it is part of Enterprise 10.7, I don't think $originalFeature will be available. It was introduced at version 1.9 (January 2020), see: Release Notes | ArcGIS for Developers. And when you look at the Version Matrix | ArcGIS for Developers you can see that Enterprise 10.7 has Arcade version 1.5 and Arcade 1.9 was introduced in Enterprise 10.8.

Reply
0 Kudos