arcgis online can not load shp file

07-11-2015 02:33 AM
New Contributor

I am trying to load .shp file to online. I put it to zip file and has .dbf .prj .qpj .shp .shx files in zip. It can be opened in QGIS, CartoDB, but when I trying to import arcgis online (My Content -> Add Item -> From My Computer) it gives Unable to load http://[myadress][myuser]/addItem status: 413

my screenshot

Do you have any idea to solve this problem?

Tags (1)
0 Kudos
2 Replies
Frequent Contributor

Your shapefile is probably too large - try it with a smaller file. You may also want to have a look at best practices for ArcGIS Online regarding shapefile size and how to reduce it:

Shapefiles—ArcGIS Online Help | ArcGIS

In a nutshell, here are the limitations:

  • Compression formats other than a .zip archive are not supported.
  • Files containing more than 1,000 features cannot be added to a map.
  • The shapefile must be less than 10 MB in size.
  • The following features are not supported: multipatch or multipoint geometries, geometries that cross the dateline, or self-intersections in polygons. Shapefiles with these features cannot be added to a map.
  • Shapefiles cannot be dragged directly onto the map viewer; you must use the Add button in the map viewer.
New Contributor

I ran into the same problem, and here is what finally worked.

The shapefile that ArcGIS needs include the .dbf, .prj, .shp, and .shx files. When I had created a shapefile from another program, I also got those four, plus a .cpg file. And I couldn't load the five files in a zipped folder--I kept getting an error. What finally worked for me was making sure the name of the files have no spaces. Then, I erased the .cpg file, placing only the .dbf, .prj, .shp, and .shx files into their own folder for the layer. Then, I zipped that folder, which was about 6MB. Finally, I dragged and dropped that zipped folder into the prompt box that you get when you add a layer from your own files into ArcGIS online.

0 Kudos