ArcExplorer on Android crash on attribute search

474
2
10-27-2016 07:26 AM
Highlighted
New Contributor III

One layer FGDB or Registered Oracle via ArcGIS 10.3 service with Query turned on get “Unfortunately, Explorer has stopped” when trying to query attribute fields (varchar2) multipoint data records when other point and polygon layers search OK. Same layer can be searched in ArcMap and via the REST query string to the service. It only crashes the ArcExplorer on the mobile device with the “Unfortunately, Explorer has stopped” message. I will attempt to publish a single point record by converting the multipoint with Arc tools to see if matters. This is read-only data, it maps correctly and seems good otherwise. What are the conditions that cause this message with Arc Explorer?

Had DBA add GLOBALID and re-index now working. Would be helpful if App didn't crash without some helpful message.

Tags (1)
Reply
0 Kudos
2 Replies
Highlighted
New Contributor

I know this is an older post, but were you ever able to find a solution to this issue? I'm currently deploying Explorer on a few android tablets, and have this same issue when enabling locates. I was able to find a workaround by publishing our explorer map to AGOL and enabling searching of layers there, but this is extremely time consuming, and creates problems with automating new map creation. 

Searching works fine on Iphone and Ipad, but crashes on our android tablets.

Thanks.

Reply
0 Kudos
Highlighted
New Contributor III

As you say it has been a while and that is no longer an issue, my recollection and notes indicated that we had ad DBA add GLOBALID and re-index and changed or collapsed the multipoint to a single point and things improved. I believe the map currently is coming out of AGOL since then so not exactly the same any more. Hope that helps.

Reply
0 Kudos