upgrade

982
8
Jump to solution
01-03-2017 01:20 AM
jayasudha
New Contributor III

(1)

We have one database on Oracle 11.2.0.1.0. After sometime we upgraded Oracle to 11.2.0.3.0
When I check properties, upgrade button not is enabled.

(2)

We have created another database on Oracle 11.2.0.3.0. Then installed Arcgis desktop 10.1 SP1.
The upgrade button not enabled on first database. But the upgrade button is enabled on second database.

======


I want to know why it is enabled only on second database.
Can i go ahead with upgrade for second database only ?

0 Kudos
1 Solution

Accepted Solutions
Asrujit_SenGupta
MVP Regular Contributor

You could be encountering a known NIM:

NIM086410: Upgrading an Enterprise geodatabase using a database.. 

[ NIM086410 - Upgrading an Enterprise geodatabase using a database connection established with the traditional syntax for direct connections fails with error 'ORA-00933: SQL command not properly ended']


Try creating a new connection to the Oracle geodatabase using only the TNSNAME(oracle netservice_name) and then try the upgrade.

Another GeoNet thread for reference to this: https://community.esri.com/thread/103191 

View solution in original post

8 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Jaya,

The Upgrade Geodatabase button only applies to the geodatabase portion.  This will only become enabled when you upgrade to another version of ArcGIS Desktop (i.e. upgrade from ArcGIS 10.3 to 10.4.1).  This button will not be enabled when you upgrade the Oracle database version.

jayasudha
New Contributor III

Thanks for that.

I tried to upgrade and got following error. The required DLL libst_shapelib.so is copied in server and set it in extproc.ora


Connected RDBMS instance is not setup for ST_GEOMETRY configuration.
[Unable to determine current version of ST_SHAPELIB.
The latest ST_GEOMETRY and dependent libraries need to be copied to the correct software location.
Refer to the ArcGIS help topics for more details.
]

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

If that message is in Green, then it is just a warning,not an error.

This warning will be highlighted in green in the Pre-requisite check and the Upgrade process when you run the upgrade in ArcCatalog, but it will not prevent you from upgrading successfully.

0 Kudos
jayasudha
New Contributor III

Thanks for that.

Upgrade is failed. There is error in sde_setup.log
Error: Underlying DBMS error (-51).

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

what is the error in the sde_setup.log file? Can you copy and paste the relevant content of the log file here...

0 Kudos
jayasudha
New Contributor III

[Wed Jan 04 10:45:54 2017]
ST_Geometry Schema Owner: (SDE) Type Release: 1007
[Wed Jan 04 10:45:54 2017] Instance initialized for ((sde)) . . .

[Wed Jan 04 10:45:54 2017] Error: Underlying DBMS error (-51).
[Wed Jan 04 10:45:54 2017] Error: DB_arcsde_setup: Unable to connect
[Wed Jan 04 10:45:54 2017] ORA-00933: SQL command not properly ended

[Wed Jan 04 10:45:54 2017] ERROR installing/upgrading ArcSDE, Error = -51

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

You could be encountering a known NIM:

NIM086410: Upgrading an Enterprise geodatabase using a database.. 

[ NIM086410 - Upgrading an Enterprise geodatabase using a database connection established with the traditional syntax for direct connections fails with error 'ORA-00933: SQL command not properly ended']


Try creating a new connection to the Oracle geodatabase using only the TNSNAME(oracle netservice_name) and then try the upgrade.

Another GeoNet thread for reference to this: https://community.esri.com/thread/103191 

jayasudha
New Contributor III

Many Thanks, It is upgraded.

0 Kudos