Select to view content in your preferred language

Unable to fetch all records from feature class through rest api

371
2
03-26-2024 04:46 AM
Labels (2)
ROHANWAJEKAR
New Contributor

Hello Community,

I am a new user of ArcGIS and currently exploring ARCMap with geodatabase linked with .sde. I am unable to fetch all records(new) from the Rest API calls for a MS SQL server geodatabase. The API calls are made to ARCGIS Server. 

1. Following is the data from FeatureClass table desc sorted on objectID field. First column is objectid. Cannot fetch ID 96532 which is basically last record.

1.png

2. Below is API query for objectID=96144 which outputs result, as available in geodatabase

2.png

3. Below is API query for objectID=96532(last record) which does not provide result though available in geodatabase

3.png

This is happening for all FeatureClass tables updated with new data.

Definition query has been updated to select records upto last objectID, for all these tables, but still the API query does not provide output for the newly loaded records.

Is there any other feature which basically restricts data output (for optimisation) and needs to be updated post Load Data process.

0 Kudos
2 Replies
JoshuaBixby
MVP Esteemed Contributor

If new data is being created in the enterprise geodatabase and not seen on the published service, I would check whether the new data and published data are using the same geodatabase version (not software version, but geodatabase version as in versioned data).  It might be necessary to reconcile and post the data to a parent version before it shows up in the service.

ROHANWAJEKAR
New Contributor

Thanks for your response.

Yes, the geodatabase is versioned, however, the sde points to default version and no new versions were created. The edits were made directly to the sde without creating versions.

Reconcile/Post are greyed out as no new versions were created. Version manager shows just one(default-owner-dbo) version.

Is there any other options besides 'Compress Database'.

Will the below solution help in this case. 

https://community.esri.com/t5/data-management-questions/properly-editing-sde-default-version/td-p/60...

 

0 Kudos