Unable to Add a Database Server in ArcCatalog...

1251
4
12-03-2013 09:59 AM
DanBihari
New Contributor III
I've installed an instance of SQL Server Express, successfully registered it and configured it.  No matter what I try, I am unable to connect to it through Add Database Server.  I can connect to it on the server side but not the client side.

SQL Server Browser is running...
SQL Server (<instance>) is running...

Shared Memory, Named Pipes and TCP/IP are all enabled.

Under Server Roles I have both "public" and "sysadmin" checked.

On the client side, the only way I can get Add Database Server to work is if I include a port number (i.e. myserver\<instance>,58524).  The problem that I run into is that the status of the database server in unknown (little white box on the server icon).  When I view my Database Server properties, my Status in unknown as well as my Class is unknown.  Without these two properties populated, I am unable to do anything with the database.

My server is running Windows Server 2008 R2 (64-bit) and ArcGIS Server 10.1.  As mentioned earlier, I'm using SQL Server 2008 R2 (Express).

Any assistance or suggestions would be greatly appreciated.

Thanks Everyone.
0 Kudos
4 Replies
AsrujitSengupta
Regular Contributor III
Dan,

Are you working with ArcSDE Personal or ArcSDE Workgroup?

Have you enabled the SQL Server Express instance, if you are using any one of the above?

On the database server, is the Firewall turned on? If yes, does turning-off the Firewall allow you to connect w/o using the port # ?

1433 and 1434 are the port # used by SQL Server. Try adding them to exceptions on the Database Server, if the firewall is the issue.
0 Kudos
MarcoBoeringa
MVP Regular Contributor
As an addition to what Asrujit wrote, if attempting to install a Personal ArcSDE a.k.a. Desktop Geodatatabase a.k.a. ArcSDE Personal Server, than you may wish to have a look at the detailed "installation" instructions I posted here:

http://forums.arcgis.com/threads/2712-Personal-SDE?p=341454&viewfull=1#post341454

Although this might well be some firewall issue as Asrujit also suggested...
0 Kudos
DanBihari
New Contributor III
I'm working with ArcSDE Workgroup.

Waiting to hear back from our IT server group with the answer to your questions.

Thank you for your responses.

~Dan
0 Kudos
ÅkeMagnusson1
New Contributor II

Hi Dan,

I seem to have the same problem that you describe in this thread.

I was wondering if you were able to solve it and if so how?

Thanks,

Åke

0 Kudos